Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M

CVE-2026-34070LangChain Core has Path Traversal vulnerabilites in legacy `load_prompt` functions

High 7.5

In plain English

A high-severity path traversal in langchain from langchain-ai. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 73% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.4%top 26.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Public PoC

Official description

LangChain is a framework for building agents and LLM-powered applications. Prior to version 1.2.22, multiple functions in langchain_core.prompts.loading read files from paths embedded in deserialized config dicts without validating against directory traversal or absolute path injection. When an application passes user-influenced prompt configurations to load_prompt() or load_prompt_from_config(), an attacker can read arbitrary files on the host filesystem, constrained only by file-extension checks (.txt for templates, .json/.yaml for examples). This issue has been patched in version 1.2.22.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIlangchain-core1.2.22GHSA-qh6h-p6c9-ff54
PyPIlangchain-core1.2.22PYSEC-2026-2193

Affected products (as reported)

VendorProductVersions
langchain-ai langchain < 1.2.22

Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References