Vulnerability · Published Apr 13, 2026 · Assigned by GitHub_M

CVE-2026-33908ImageMagick is vulnerable to Stack Overflow in DestroyXMLTree()

High 7.5

In plain English

A high-severity security flaw in ImageMagick from ImageMagick. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 56.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

ImageMagick is free and open-source software used for editing and manipulating digital images. In versions below both 7.1.2-19 and 6.9.13-44, Magick frees the memory of the XML tree via the `DestroyXMLTree()` function; however, this process is executed recursively with no depth limit imposed. When Magick processes an XML file with deeply nested structures, it will exhaust the stack memory, resulting in a Denial of Service (DoS) attack. This issue has been fixed in versions 6.9.13-44 and 7.1.2-19.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23imagemagick7.1.2.19-r0ALPINE-CVE-2026-33908
Alpine:v3.24imagemagick7.1.2.19-r0ALPINE-CVE-2026-33908
Debian:12imagemagick8:6.9.11.60+dfsg-1.6+deb12u9DEBIAN-CVE-2026-33908
Debian:13imagemagick8:7.1.1.43+dfsg1-1+deb13u8DEBIAN-CVE-2026-33908
Debian:14imagemagick8:7.1.2.19+dfsg1-1DEBIAN-CVE-2026-33908
NuGetmagick.net-q16-anycpu14.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q16-arm6414.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q16-hdri-anycpu14.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q16-hdri-arm6414.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q16-hdri-openmp-arm6414.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q16-hdri-x6414.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q16-hdri-x8614.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q16-openmp-arm6414.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q16-openmp-x6414.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q16-x6414.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q16-x8614.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q8-anycpu14.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q8-arm6414.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q8-openmp-arm6414.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q8-openmp-x6414.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q8-x6414.12.0GHSA-fwvm-ggf6-2p4x
NuGetmagick.net-q8-x8614.12.0GHSA-fwvm-ggf6-2p4x
Ubuntu:25.10imagemagickno fix listedUBUNTU-CVE-2026-33908
Ubuntu:26.10imagemagickno fix listedUBUNTU-CVE-2026-33908

Affected products (as reported)

VendorProductVersions
ImageMagick ImageMagick < 6.9.13-44< 7.1.2-19

Weakness: CWE-674, CWE-776 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References