Vulnerability · Published Apr 13, 2026 · Assigned by GitHub_M
CVE-2026-33902ImageMagick: Stack Overflow via Recursive FX Expression Parsing
Medium 5.5
In plain English
A medium-severity security flaw in ImageMagick from ImageMagick. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
ImageMagick is free and open-source software used for editing and manipulating digital images. In versions below both 7.1.2-19 and 6.9.13-44, a stack overflow vulnerability in ImageMagick's FX expression parser allows an attacker to crash the process by providing a deeply nested expression. This issue has been fixed in versions 6.9.13-44 and 7.1.2-19.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | imagemagick | 7.1.2.19-r0 | ALPINE-CVE-2026-33902 |
| Alpine:v3.24 | imagemagick | 7.1.2.19-r0 | ALPINE-CVE-2026-33902 |
| Debian:13 | imagemagick | 8:7.1.1.43+dfsg1-1+deb13u8 | DEBIAN-CVE-2026-33902 |
| Debian:14 | imagemagick | 8:7.1.2.19+dfsg1-1 | DEBIAN-CVE-2026-33902 |
| NuGet | magick.net-q16-anycpu | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q16-arm64 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q16-hdri-anycpu | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q16-hdri-arm64 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q16-hdri-openmp-arm64 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q16-hdri-x64 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q16-hdri-x86 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q16-openmp-arm64 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q16-openmp-x64 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q16-x64 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q16-x86 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q8-anycpu | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q8-arm64 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q8-openmp-arm64 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q8-openmp-x64 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q8-x64 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| NuGet | magick.net-q8-x86 | 14.12.0 | GHSA-f4qm-vj5j-9xpw |
| Ubuntu:25.10 | imagemagick | no fix listed | UBUNTU-CVE-2026-33902 |
| Ubuntu:26.10 | imagemagick | no fix listed | UBUNTU-CVE-2026-33902 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ImageMagick | ImageMagick | < 7.1.2-19< 6.9.13-44 |
Weakness: CWE-674 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H