Vulnerability · Published Apr 13, 2026 · Assigned by GitHub_M

CVE-2026-33900ImageMagick has a Heap overflow caused by integer overflow/wraparound in viff encoder on 32-bit builds

Medium 5.9

In plain English

A medium-severity integer overflow in ImageMagick from ImageMagick. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.4%top 62.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

ImageMagick is free and open-source software used for editing and manipulating digital images. In versions below both 7.1.2-19 and 6.9.13-44, the viff encoder contains an integer truncation/wraparound issue on 32-bit builds that could trigger an out of bounds heap write, potentially causing a crash. This issue has been fixed in versions 6.9.13-44 and 7.1.2-19.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23imagemagick7.1.2.19-r0ALPINE-CVE-2026-33900
Alpine:v3.24imagemagick7.1.2.19-r0ALPINE-CVE-2026-33900
Debian:12imagemagick8:6.9.11.60+dfsg-1.6+deb12u9DEBIAN-CVE-2026-33900
Debian:13imagemagick8:7.1.1.43+dfsg1-1+deb13u8DEBIAN-CVE-2026-33900
Debian:14imagemagick8:7.1.2.19+dfsg1-1DEBIAN-CVE-2026-33900
NuGetmagick.net-q16-anycpu14.12.0GHSA-v67w-737x-v2c9
NuGetmagick.net-q16-hdri-anycpu14.12.0GHSA-v67w-737x-v2c9
NuGetmagick.net-q16-hdri-x8614.12.0GHSA-v67w-737x-v2c9
NuGetmagick.net-q16-x8614.12.0GHSA-v67w-737x-v2c9
NuGetmagick.net-q8-anycpu14.12.0GHSA-v67w-737x-v2c9
NuGetmagick.net-q8-x8614.12.0GHSA-v67w-737x-v2c9
Ubuntu:25.10imagemagickno fix listedUBUNTU-CVE-2026-33900

Affected products (as reported)

VendorProductVersions
ImageMagick ImageMagick < 6.9.13-44< 7.1.2-19

Weakness: CWE-190 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

References