Vulnerability · Published Mar 24, 2026 · Assigned by GitHub_M

CVE-2026-33624Parse Server: MFA recovery code single-use bypass via concurrent requests

Low 2.1

In plain English

A low-severity security flaw in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.1Low
Exploit odds (30 days)0.2%top 92.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.60 and 9.6.0-alpha.54, an attacker who obtains a user's password and a single MFA recovery code can reuse that recovery code an unlimited number of times by sending concurrent login requests. This defeats the single-use design of recovery codes. The attack requires the user's password, a valid recovery code, and the ability to send concurrent requests within milliseconds. This issue has been patched in versions 8.6.60 and 9.6.0-alpha.54.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.6.0-alpha.54GHSA-2299-ghjr-6vjp
npmparse-server8.6.60GHSA-2299-ghjr-6vjp

Affected products (as reported)

VendorProductVersions
parse-community parse-server < 8.6.60>= 9.0.0, < 9.6.0-alpha.54

Weakness: CWE-367 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

References