Vulnerability · Published Apr 17, 2026 · Assigned by GitHub_M

CVE-2026-33516xrdp: Pre-authentication out-of-bounds reads in RDP capability and channel parsers

High 7.7

In plain English

A high-severity out-of-bounds read in xrdp from neutrinolabs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.7High
Exploit odds (30 days)0.4%top 62.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

xrdp is an open source RDP server. Versions through 0.10.5 contain an out-of-bounds read vulnerability during the RDP capability exchange phase. The issue occurs when memory is accessed before validating the remaining buffer length. A remote, unauthenticated attacker can trigger this vulnerability by sending a specially crafted Confirm Active PDU. Successful exploitation could lead to a denial of service (process crash) or potential disclosure of sensitive information from the process memory. This issue has been fixed in version 0.10.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23xrdp0.10.6-r0ALPINE-CVE-2026-33516
Alpine:v3.24xrdp0.10.6-r0ALPINE-CVE-2026-33516
Debian:12xrdp0.9.21.1-1+deb12u3DEBIAN-CVE-2026-33516
Debian:13xrdp0.10.1-3.1+deb13u2DEBIAN-CVE-2026-33516
Debian:14xrdp0.10.6-1DEBIAN-CVE-2026-33516
Ubuntu:22.04:LTSxrdpno fix listedUBUNTU-CVE-2026-33516
Ubuntu:24.04:LTSxrdpno fix listedUBUNTU-CVE-2026-33516
Ubuntu:25.10xrdpno fix listedUBUNTU-CVE-2026-33516
Ubuntu:26.04:LTSxrdpno fix listedUBUNTU-CVE-2026-33516
Ubuntu:26.10xrdpno fix listedUBUNTU-CVE-2026-33516

Affected products (as reported)

VendorProductVersions
neutrinolabs xrdp < 0.10.6

Weakness: CWE-125 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References