Vulnerability · Published Apr 15, 2026 · Assigned by GitHub_M
CVE-2026-33435Weblate: Remote code execution during backup restoration
High 8.1
In plain English
A high-severity code injection in weblate from WeblateOrg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Weblate is a web based localization tool. In versions prior to 5.17, the project backup didn't filter Git and Mercurial configuration files which could lead to remote code execution under certain circumstances. This issue has been fixed in version 5.17. If developers are unable to update immediately, they can limit the scope of the vulnerability by restricting access to the project backup, as it is only accessible to users who can create projects.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | weblate | 5.17 | GHSA-558g-h753-6m33 |
| PyPI | weblate | 5.17 | PYSEC-2026-154 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| WeblateOrg | weblate | < 5.17 |
Weakness: CWE-23, CWE-94, CWE-434 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-558g-h753-6m33 x_refsource_CONFIRM
- https://github.com/WeblateOrg/weblate/pull/18549 x_refsource_MISC