Vulnerability · Published Apr 14, 2026 · Assigned by GitHub_M

CVE-2026-33414PowerShell Command Injection in Podman HyperV Machine

High 8.8

In plain English

A high-severity OS command injection in podman from containers. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.6%top 50.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Podman is a tool for managing OCI containers and pods. Versions 4.8.0 through 5.8.1 contain a command injection vulnerability in the HyperV machine backend in pkg/machine/hyperv/stubber.go, where the VM image path is inserted into a PowerShell double-quoted string without sanitization, allowing $() subexpression injection. Because PowerShell evaluates subexpressions inside double-quoted strings before executing the outer command, an attacker who can control the VM image path through a crafted machine name or image directory can execute arbitrary PowerShell commands with the privileges of the Podman process. On typical Windows installations this means SYSTEM-level code execution, and only Windows is affected as the code is exclusive to the HyperV backend. This issue has been patched in version 5.8.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13podmanno fix listedDEBIAN-CVE-2026-33414
Debian:14podman5.8.2+ds1-1DEBIAN-CVE-2026-33414
Gogithub.com/containers/podmanno fix listedGO-2026-5421
Gogithub.com/containers/podman/v2no fix listedGO-2026-5421
Gogithub.com/containers/podman/v3no fix listedGO-2026-5421
Gogithub.com/containers/podman/v4no fix listedGO-2026-5421
Gogithub.com/containers/podman/v4no fix listedGHSA-hc8w-h2mf-hp59
Gogithub.com/containers/podman/v55.8.2GO-2026-5421
Gogithub.com/containers/podman/v55.8.2GHSA-hc8w-h2mf-hp59
Ubuntu:25.10podmanno fix listedUBUNTU-CVE-2026-33414
Ubuntu:26.04:LTSpodmanno fix listedUBUNTU-CVE-2026-33414
Ubuntu:26.10podmanno fix listedUBUNTU-CVE-2026-33414

Affected products (as reported)

VendorProductVersions
containers podman >= 4.8.0, < 5.8.2

Weakness: CWE-78, CWE-94 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

References