Vulnerability · Published Mar 24, 2026 · Assigned by GitHub_M

CVE-2026-33409Parse Server: Auth provider validation bypass on login via partial authData

High 7.0

In plain English

A high-severity improper authentication in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.0High
Exploit odds (30 days)0.5%top 58.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0-alpha.41, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0-alpha.41.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.6.0-alpha.41GHSA-pfj7-wv7c-22pr
npmparse-server8.6.52GHSA-pfj7-wv7c-22pr

Affected products (as reported)

VendorProductVersions
parse-community parse-server < 8.6.52>= 9.0.0, < 9.6.0-alpha.41

Weakness: CWE-287 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References