Vulnerability · Published Mar 20, 2026 · Assigned by GitHub_M

CVE-2026-33210Ruby JSON has a format string injection vulnerability

Critical 9.1

In plain English

A critical-severity security flaw in json from ruby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.9%top 40.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Ruby JSON is a JSON implementation for Ruby. From version 2.14.0 to before versions 2.15.2.1, 2.17.1.2, and 2.19.2, a format string injection vulnerability can lead to denial of service attacks or information disclosure, when the allow_duplicate_key: false parsing option is used to parse user supplied documents. This issue has been patched in versions 2.15.2.1, 2.17.1.2, and 2.19.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:9ruby4.0.3-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9ruby-bundled-gems4.0.3-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9ruby-default-gems4.0.3-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9ruby-devel4.0.3-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9ruby-doc4.0.3-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9ruby-libs4.0.3-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:10ruby4.04.0.3-34.el10_2ALSA-2026:20606
AlmaLinux:10ruby4.0-devel4.0.3-34.el10_2ALSA-2026:20606
AlmaLinux:10ruby4.0-doc4.0.3-34.el10_2ALSA-2026:20606
AlmaLinux:10ruby4.0-rubygem-mysql20.5.7-34.el10_2ALSA-2026:20606
AlmaLinux:10ruby4.0-rubygem-pg1.6.3-34.el10_2ALSA-2026:20606
AlmaLinux:9rubygem-bigdecimal4.0.1-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-bundler4.0.6-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-io-console0.8.2-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-irb1.16.0-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-json2.18.0-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-minitest6.0.0-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-mysql20.5.7-1.module_el9.8.0+232+50f6dd36ALSA-2026:20596
AlmaLinux:9rubygem-mysql2-doc0.5.7-1.module_el9.8.0+232+50f6dd36ALSA-2026:20596
AlmaLinux:9rubygem-pg1.6.3-1.module_el9.8.0+232+50f6dd36ALSA-2026:20596
AlmaLinux:9rubygem-pg-doc1.6.3-1.module_el9.8.0+232+50f6dd36ALSA-2026:20596
AlmaLinux:9rubygem-power_assert3.0.1-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-psych5.3.1-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-racc1.8.1-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-rake13.3.1-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-rbs3.10.0-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-rdoc7.0.3-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-rexml3.4.4-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-rss0.3.2-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-test-unit3.7.5-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygem-typeprof0.31.1-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygems4.0.6-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
AlmaLinux:9rubygems-devel4.0.6-32.module_el9.8.0+251+5fdbd96bALSA-2026:20596
Debian:14ruby-json2.19.2+dfsg-1DEBIAN-CVE-2026-33210
Rocky Linux:10ruby4.00:4.0.3-34.el10_2RLSA-2026:20606
Rocky Linux:9rubygem-mysql20:0.5.7-1.module+el9.8.0+40094+ce01217cRLSA-2026:20596
Rocky Linux:9rubygem-pg0:1.6.3-1.module+el9.8.0+40094+ce01217cRLSA-2026:20596
RubyGemsjson2.19.2GHSA-3m6g-2423-7cp3
RubyGemsjson2.15.2.1GHSA-3m6g-2423-7cp3
RubyGemsjson2.17.1.2GHSA-3m6g-2423-7cp3
Ubuntu:22.04:LTSruby-jsonno fix listedUBUNTU-CVE-2026-33210
Ubuntu:24.04:LTSruby-jsonno fix listedUBUNTU-CVE-2026-33210
Ubuntu:25.10ruby-jsonno fix listedUBUNTU-CVE-2026-33210
Ubuntu:26.04:LTSruby-jsonno fix listedUBUNTU-CVE-2026-33210
Ubuntu:26.10ruby-jsonno fix listedUBUNTU-CVE-2026-33210

Affected products (as reported)

VendorProductVersions
ruby json >= 2.14.0, < 2.15.2.1>= 2.16.0, < 2.17.1.2>= 2.18.0, < 2.19.2

Weakness: CWE-134 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

References