Vulnerability · Published Feb 27, 2026 · Assigned by openjs

CVE-2026-3304Multer vulnerable to Denial of Service via incomplete cleanup

High 7.5

In plain English

A high-severity security flaw in multer from expressjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.7%top 45.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmmulter2.1.0GHSA-xf7r-hgr6-v32p

Affected products (as reported)

VendorProductVersions
expressjs multer 0.0.0 – before 2.1.0

Weakness: CWE-459 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References