Vulnerability · Published Mar 30, 2026 · Assigned by GitHub_M
CVE-2026-33028Nginx UI: Race Condition Leads to Persistent Data Corruption and Service Collapse
High 7.1
In plain English
A high-severity race condition in nginx-ui from 0xJacky. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, the nginx-ui application is vulnerable to a Race Condition. Due to the complete absence of synchronization mechanisms (Mutex) and non-atomic file writes, concurrent requests lead to the severe corruption of the primary configuration file (app.ini). This vulnerability results in a persistent Denial of Service (DoS) and introduces a non-deterministic path for Remote Code Execution (RCE) through configuration cross-contamination. This issue has been patched in version 2.3.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/0xJacky/Nginx-UI | no fix listed | GHSA-m468-xcm6-fxg4 |
| Go | github.com/0xJacky/Nginx-UI | no fix listed | GO-2026-4906 |
| Go | github.com/uozi-tech/cosy | 1.30.1 | GHSA-m468-xcm6-fxg4 |
| Go | github.com/uozi-tech/cosy | 1.30.1 | GO-2026-4906 |
Affected products (as reported)
Weakness: CWE-362 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-m468-xcm6-fxg4 x_refsource_CONFIRM
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.4 x_refsource_MISC