Vulnerability · Published Mar 20, 2026 · Assigned by GitHub_M

CVE-2026-32935phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack

High 8.2

In plain English

A high-severity security flaw in phpseclib from phpseclib. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.4%top 65.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

phpseclib is a PHP secure communications library. Projects using versions 0.1.1 through 1.0.26, 2.0.0 through 2.0.51, and 3.0.0 through 3.0.49 are vulnerable to a to padding oracle timing attack when using AES in CBC mode. This issue has been fixed in versions 1.0.27, 2.0.52 and 3.0.50.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12php-phpseclib2.0.42-1+deb12u3DSA-6186-1
Debian:12php-phpseclib2.0.42-1+deb12u3DEBIAN-CVE-2026-32935
Debian:13php-phpseclib2.0.48-3+deb13u1DSA-6186-1
Debian:13php-phpseclib2.0.48-3+deb13u1DEBIAN-CVE-2026-32935
Debian:14php-phpseclib2.0.52-1DEBIAN-CVE-2026-32935
Debian:12php-phpseclib33.0.19-1+deb12u4DEBIAN-CVE-2026-32935
Debian:12php-phpseclib33.0.19-1+deb12u4DSA-6187-1
Debian:13php-phpseclib33.0.43-2+deb13u1DEBIAN-CVE-2026-32935
Debian:13php-phpseclib33.0.43-2+deb13u1DSA-6187-1
Debian:14php-phpseclib33.0.50-1DEBIAN-CVE-2026-32935
Debian:12phpseclib1.0.20-1+deb12u3DSA-6185-1
Debian:12phpseclib1.0.20-1+deb12u3DEBIAN-CVE-2026-32935
Debian:13phpseclib1.0.23-6+deb13u1DSA-6185-1
Debian:13phpseclib1.0.23-6+deb13u1DEBIAN-CVE-2026-32935
Packagistphpseclib/phpseclib1.0.27GHSA-94g3-g5v7-q4jg
Packagistphpseclib/phpseclib2.0.52GHSA-94g3-g5v7-q4jg
Packagistphpseclib/phpseclib3.0.50GHSA-94g3-g5v7-q4jg
Ubuntu:25.10php-phpseclibno fix listedUBUNTU-CVE-2026-32935
Ubuntu:24.04:LTSphp-phpseclib3no fix listedUBUNTU-CVE-2026-32935
Ubuntu:25.10php-phpseclib3no fix listedUBUNTU-CVE-2026-32935
Ubuntu:26.04:LTSphp-phpseclib3no fix listedUBUNTU-CVE-2026-32935
Ubuntu:26.10php-phpseclib3no fix listedUBUNTU-CVE-2026-32935
Ubuntu:22.04:LTSphpseclib1.0.20-1+deb12u3build0.22.04.1UBUNTU-CVE-2026-32935
Ubuntu:22.04:LTSphpseclib1.0.20-1+deb12u3build0.22.04.1USN-8769-1
Ubuntu:25.10phpseclibno fix listedUBUNTU-CVE-2026-32935

Affected products (as reported)

VendorProductVersions
phpseclib phpseclib >= 3.0.0, < 3.0.50>= 2.0.0, < 2.0.52>= 0.1.1, < 1.0.27

Weakness: CWE-208 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References