Vulnerability · Published Mar 20, 2026 · Assigned by GitHub_M
CVE-2026-32891Anchorr Privilege Escalation: Jellyseerr User → Anchorr Admin via Stored XSS
Critical 9.1
In plain English
A critical-severity security flaw in Anchorr from openVESSL. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities).
Official description
Anchorr is a Discord bot for requesting movies and TV shows and receiving notifications when items are added to a media server. Versions 1.4.1 and below contain a stored XSS vulnerability in the Jellyseerr user selector. Jellyseerr allows any account holder to execute arbitrary JavaScript in the Anchorr admin's browser session. The injected script calls the authenticated /api/config endpoint - which returns the full application configuration in plaintext. This allows the attacker to forge a valid Anchorr session token and gain full admin access to the dashboard with no knowledge of the admin password. The same response also exposes the API keys and tokens for every integrated service, resulting in simultaneous account takeover of the Jellyfin media server (via JELLYFIN_API_KEY), the Jellyseerr request manager (via JELLYSEERR_API_KEY), and the Discord bot (via DISCORD_TOKEN). This issue has been fixed in version 1.4.2.
Affected products (as reported)
Weakness: CWE-80, CWE-212, CWE-311 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
References
- https://github.com/openVESSL/Anchorr/security/advisories/GHSA-6mg4-788h-7g9g x_refsource_CONFIRM
- https://github.com/openVESSL/Anchorr/releases/tag/v1.4.2 x_refsource_MISC