Vulnerability · Published Sep 18, 2026 · Assigned by GitHub_M
CVE-2026-32641Parseable: Unauthenticated Denial of Service via panic in Kinesis header parsing middleware
High 7.5
In plain English
A high-severity security flaw in parseable from parseablehq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities).
Official description
Parseable is a log analytics platform built for high-volume data ingestion and analysis. Prior to 3.0.0, src/handlers/http/middleware.rs uses unwrap() while parsing the x-amz-firehose-common-attributes header before authentication. A remote unauthenticated attacker can supply non-UTF-8 header data, malformed JSON, or invalid derived header values that trigger a Rust panic and interrupt request handling, allowing repeated requests to deny service or cause container restart loops. This issue is fixed in version 3.0.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| parseablehq | parseable | < 3.0.0 |
Weakness: CWE-248, CWE-703 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/parseablehq/parseable/security/advisories/GHSA-x4q9-j9qh-3rpx x_refsource_CONFIRM
- https://github.com/parseablehq/parseable/pull/1581 x_refsource_MISC
- https://github.com/parseablehq/parseable/commit/6c583081a4161476128f330b9bb71ed7305eecde x_refsource_MISC
- https://github.com/parseablehq/parseable/releases/tag/v3.0.0 x_refsource_MISC