Vulnerability · Published Mar 13, 2026 · Assigned by GitHub_M
CVE-2026-32635Angular has XSS in i18n attribute bindings
High 8.6
In plain English
A high-severity cross-site scripting in compiler from @angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20, a Cross-Site Scripting (XSS) vulnerability has been identified in the Angular runtime and compiler. It occurs when the application uses a security-sensitive attribute (for example href on an anchor tag) together with Angular's ability to internationalize attributes. Enabling internationalization for the sensitive attribute by adding i18n-<attribute> name bypasses Angular's built-in sanitization mechanism, which when combined with a data binding to untrusted user-generated data can allow an attacker to inject a malicious script. This vulnerability is fixed in 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | angular.js | no fix listed | DEBIAN-CVE-2026-32635 |
| Debian:13 | angular.js | no fix listed | DEBIAN-CVE-2026-32635 |
| Ubuntu:22.04:LTS | angular.js | no fix listed | UBUNTU-CVE-2026-32635 |
| Ubuntu:24.04:LTS | angular.js | no fix listed | UBUNTU-CVE-2026-32635 |
| Ubuntu:25.10 | angular.js | no fix listed | UBUNTU-CVE-2026-32635 |
| Ubuntu:26.04:LTS | angular.js | no fix listed | UBUNTU-CVE-2026-32635 |
| Ubuntu:26.10 | angular.js | no fix listed | UBUNTU-CVE-2026-32635 |
| npm | @angular/compiler | 19.2.20 | GHSA-g93w-mfhg-p222 |
| npm | @angular/compiler | 22.0.0-next.3 | GHSA-g93w-mfhg-p222 |
| npm | @angular/compiler | 21.2.4 | GHSA-g93w-mfhg-p222 |
| npm | @angular/compiler | 20.3.18 | GHSA-g93w-mfhg-p222 |
| npm | @angular/compiler | no fix listed | GHSA-g93w-mfhg-p222 |
| npm | @angular/core | 22.0.0-next.3 | GHSA-g93w-mfhg-p222 |
| npm | @angular/core | no fix listed | GHSA-g93w-mfhg-p222 |
| npm | @angular/core | 19.2.20 | GHSA-g93w-mfhg-p222 |
| npm | @angular/core | 20.3.18 | GHSA-g93w-mfhg-p222 |
| npm | @angular/core | 21.2.4 | GHSA-g93w-mfhg-p222 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/angular/angular/security/advisories/GHSA-g93w-mfhg-p222 x_refsource_CONFIRM
- https://github.com/angular/angular/pull/67541 x_refsource_MISC
- https://github.com/angular/angular/pull/67561 x_refsource_MISC