Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M

CVE-2026-32620Discourse: Missing post-level authorization allows whisper metadata disclosure

Medium 5.3

In plain English

A medium-severity information exposure in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities).

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.2%top 89.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, non-staff users could access read receipt information for staff-only posts they weren't supposed to see. No post content was exposed, only metadata about who read the post and when. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.

Affected products (as reported)

VendorProductVersions
discourse discourse >= 2026.1.0-latest, < 2026.1.3>= 2026.2.0-latest, < 2026.2.2>= 2026.3.0-latest, < 2026.3.0

Weakness: CWE-200 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

References