Vulnerability · Published Mar 12, 2026 · Assigned by GitHub_M
CVE-2026-32612Statamic: privilege escalation via stored cross-site scripting
Medium 5.4
In plain English
A medium-severity cross-site scripting in cms from statamic. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Statamic is a Laravel and Git powered content management system (CMS). Prior to 6.6.2, stored XSS in the control panel color mode preference allows authenticated users with control panel access to inject malicious JavaScript that executes when a higher-privileged user impersonates their account. This has been fixed in 6.6.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | statamic/cms | 6.6.2 | GHSA-hcch-w73c-jp4m |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/statamic/cms/security/advisories/GHSA-hcch-w73c-jp4m x_refsource_CONFIRM
- https://github.com/Shirshaw64p/security-advisories/tree/main/CVE-2026-32612 x_refsource_MISC