Vulnerability · Published Mar 16, 2026 · Assigned by GitHub_M
CVE-2026-32264Craft CMS vulnerable to behavior injection RCE ElementIndexesController and FieldsController
High 8.6
In plain English
A high-severity security flaw in cms from craftcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.5 and from version 5.0.0-RC1 to before version 5.9.11, there is a Behavior injection RCE vulnerability in ElementIndexesController and FieldsController. Craft control panel administrator permissions and allowAdminChanges must be enabled for this to work. This issue has been patched in versions 4.17.5 and 5.9.11.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | craftcms/cms | 4.17.5 | GHSA-4484-8v2f-5748 |
| Packagist | craftcms/cms | 5.9.11 | GHSA-4484-8v2f-5748 |
Affected products (as reported)
Weakness: CWE-470 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/craftcms/cms/security/advisories/GHSA-4484-8v2f-5748 x_refsource_CONFIRM
- https://github.com/craftcms/cms/security/advisories/GHSA-7jx7-3846-m7w7 x_refsource_MISC
- https://github.com/craftcms/cms/commit/78d181e12e0b15e1300f54ec85f19859d3300f70 x_refsource_MISC
- https://github.com/craftcms/cms/commit/dfec46362fcb40b330ce8a4d8136446e65085620 x_refsource_MISC