Vulnerability · Published Mar 12, 2026 · Assigned by GitHub_M
CVE-2026-32259ImageMagick has a possible stack buffer overflow in sixel encoder
Medium 6.7
In plain English
A medium-severity stack buffer overflow in ImageMagick from ImageMagick. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 1% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-16 and 6.9.13-41, when a memory allocation fails in the sixel encoder it would be possible to write past the end of a buffer on the stack. This vulnerability is fixed in 7.1.2-16 and 6.9.13-41.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | imagemagick | 7.1.2.17-r0 | ALPINE-CVE-2026-32259 |
| Alpine:v3.24 | imagemagick | 7.1.2.17-r0 | ALPINE-CVE-2026-32259 |
| Debian:12 | imagemagick | 8:6.9.11.60+dfsg-1.6+deb12u8 | DEBIAN-CVE-2026-32259 |
| Debian:13 | imagemagick | 8:7.1.1.43+dfsg1-1+deb13u7 | DEBIAN-CVE-2026-32259 |
| Debian:13 | imagemagick | 8:7.1.1.43+dfsg1-1+deb13u7 | DSA-6169-1 |
| Debian:14 | imagemagick | 8:7.1.2.16+dfsg1-1 | DEBIAN-CVE-2026-32259 |
| Ubuntu:25.10 | imagemagick | no fix listed | UBUNTU-CVE-2026-32259 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ImageMagick | ImageMagick | >= 7.0.0, < 7.1.2-16< 6.9.13-41 |
Weakness: CWE-121 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H