Vulnerability · Published Mar 10, 2026 · Assigned by GitHub_M

CVE-2026-30947Parse Server ha a bypass of class-level permissions in LiveQuery

High 8.7

In plain English

A high-severity incorrect authorization in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.5%top 59.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.3 and 8.6.16, class-level permissions (CLP) are not enforced for LiveQuery subscriptions. An unauthenticated or unauthorized client can subscribe to any LiveQuery-enabled class and receive real-time events for all objects, regardless of CLP restrictions. All Parse Server deployments that use LiveQuery with class-level permissions are affected. Data intended to be restricted by CLP is leaked to unauthorized subscribers in real time. This vulnerability is fixed in 9.5.2-alpha.3 and 8.6.16.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.5.2-alpha.3GHSA-7ch5-98q2-7289
npmparse-server8.6.16GHSA-7ch5-98q2-7289

Affected products (as reported)

VendorProductVersions
parse-community parse-server >= 9.0.0 < 9.5.2-alpha.3< 8.6.16

Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References