Vulnerability · Published Apr 15, 2026 · Assigned by apache

CVE-2026-30778Apache SkyWalking: The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information of MySQL/PostgreSQL.

High 7.5

In plain English

A high-severity security flaw in Apache SkyWalking from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 54.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information of MySQL/PostgreSQL. This issue affects Apache SkyWalking: from 9.7.0 through 10.3.0. Users are recommended to upgrade to version 10.4.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.skywalking:server-core10.4.0GHSA-27h3-crw2-q36w

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache SkyWalking 9.7.0 – through 10.3.0

Weakness: CWE-202 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References