Vulnerability · Published Jun 8, 2026 · Assigned by apache
CVE-2026-29170Apache HTTP Server: mod_proxy_ftp XSS
Medium 6.1
In plain English
A medium-severity cross-site scripting in Apache HTTP Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A cross-site scripting vulnerability exists in mod_proxy_ftp's HTML directory list generation in Apache HTTP Server 2.4.67 and earlier when listing FTP directory contents either via forward or reverse proxy configuration. Users are recommended to upgrade to version 2.4.68, which fixes this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.21 | apache2 | 2.4.68-r0 | ALPINE-CVE-2026-29170 |
| Alpine:v3.22 | apache2 | 2.4.68-r0 | ALPINE-CVE-2026-29170 |
| Alpine:v3.23 | apache2 | 2.4.68-r0 | ALPINE-CVE-2026-29170 |
| Alpine:v3.24 | apache2 | 2.4.68-r0 | ALPINE-CVE-2026-29170 |
| Debian:12 | apache2 | 2.4.68-1~deb12u1 | DEBIAN-CVE-2026-29170 |
| Debian:13 | apache2 | 2.4.68-1~deb13u1 | DEBIAN-CVE-2026-29170 |
| Debian:14 | apache2 | 2.4.68-1 | DEBIAN-CVE-2026-29170 |
| Ubuntu:22.04:LTS | apache2 | 2.4.52-1ubuntu4.23 | USN-8516-1 |
| Ubuntu:22.04:LTS | apache2 | 2.4.52-1ubuntu4.23 | UBUNTU-CVE-2026-29170 |
| Ubuntu:24.04:LTS | apache2 | 2.4.58-1ubuntu8.15 | USN-8516-1 |
| Ubuntu:24.04:LTS | apache2 | 2.4.58-1ubuntu8.15 | UBUNTU-CVE-2026-29170 |
| Ubuntu:25.10 | apache2 | no fix listed | UBUNTU-CVE-2026-29170 |
| Ubuntu:26.04:LTS | apache2 | 2.4.66-2ubuntu2.4 | UBUNTU-CVE-2026-29170 |
| Ubuntu:26.04:LTS | apache2 | 2.4.66-2ubuntu2.4 | USN-8516-1 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache HTTP Server | 0 – through 2.4.67 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N