Vulnerability · Published Apr 9, 2026 · Assigned by apache

CVE-2026-29146Apache Tomcat: EncryptInterceptor vulnerable to padding oracle attack by default

High 7.5

In plain English

A high-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 8.8% (higher than 95% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)8.8%top 4.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10tomcat1:10.1.49-3.el10_2.alma.1ALSA-2026:36788
AlmaLinux:8tomcat1:9.0.87-2.el8_10ALSA-2026:37137
AlmaLinux:9tomcat1:9.0.117-2.el9_8ALSA-2026:36879
AlmaLinux:10tomcat-admin-webapps1:10.1.49-3.el10_2.alma.1ALSA-2026:36788
AlmaLinux:8tomcat-admin-webapps1:9.0.87-2.el8_10ALSA-2026:37137
AlmaLinux:9tomcat-admin-webapps1:9.0.117-2.el9_8ALSA-2026:36879
AlmaLinux:10tomcat-docs-webapp1:10.1.49-3.el10_2.alma.1ALSA-2026:36788
AlmaLinux:8tomcat-docs-webapp1:9.0.87-2.el8_10ALSA-2026:37137
AlmaLinux:9tomcat-docs-webapp1:9.0.117-2.el9_8ALSA-2026:36879
AlmaLinux:8tomcat-el-3.0-api1:9.0.87-2.el8_10ALSA-2026:37137
AlmaLinux:9tomcat-el-3.0-api1:9.0.117-2.el9_8ALSA-2026:36879
AlmaLinux:10tomcat-el-5.0-api1:10.1.49-3.el10_2.alma.1ALSA-2026:36788
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.87-2.el8_10ALSA-2026:37137
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.117-2.el9_8ALSA-2026:36879
AlmaLinux:10tomcat-jsp-3.1-api1:10.1.49-3.el10_2.alma.1ALSA-2026:36788
AlmaLinux:10tomcat-lib1:10.1.49-3.el10_2.alma.1ALSA-2026:36788
AlmaLinux:8tomcat-lib1:9.0.87-2.el8_10ALSA-2026:37137
AlmaLinux:9tomcat-lib1:9.0.117-2.el9_8ALSA-2026:36879
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.87-2.el8_10ALSA-2026:37137
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.117-2.el9_8ALSA-2026:36879
AlmaLinux:10tomcat-servlet-6.0-api1:10.1.49-3.el10_2.alma.1ALSA-2026:36788
AlmaLinux:10tomcat-webapps1:10.1.49-3.el10_2.alma.1ALSA-2026:36788
AlmaLinux:8tomcat-webapps1:9.0.87-2.el8_10ALSA-2026:37137
AlmaLinux:9tomcat-webapps1:9.0.117-2.el9_8ALSA-2026:36879
AlmaLinux:10tomcat91:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-admin-webapps1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-docs-webapp1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-el-3.0-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-jsp-2.3-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-lib1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-servlet-4.0-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-webapps1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
Debian:12tomcat1010.1.55-1~deb12u1DEBIAN-CVE-2026-29146
Debian:13tomcat1010.1.55-1~deb13u1DEBIAN-CVE-2026-29146
Debian:14tomcat1010.1.54-1DEBIAN-CVE-2026-29146
Debian:13tomcat1111.0.22-1~deb13u1DEBIAN-CVE-2026-29146
Debian:14tomcat1111.0.21-1DEBIAN-CVE-2026-29146
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-29146
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-29146
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-29146
Mavenorg.apache.tomcat:tomcat10.1.53GHSA-h468-7pvh-8vr8
Mavenorg.apache.tomcat:tomcatno fix listedGHSA-h468-7pvh-8vr8
Mavenorg.apache.tomcat:tomcatno fix listedGHSA-h468-7pvh-8vr8
Mavenorg.apache.tomcat:tomcat11.0.20GHSA-h468-7pvh-8vr8
Mavenorg.apache.tomcat:tomcat9.0.116GHSA-h468-7pvh-8vr8
Mavenorg.apache.tomcat:tomcat-tribesno fix listedGHSA-h468-7pvh-8vr8
Mavenorg.apache.tomcat:tomcat-tribes9.0.116GHSA-h468-7pvh-8vr8
Mavenorg.apache.tomcat:tomcat-tribes10.1.53GHSA-h468-7pvh-8vr8
Mavenorg.apache.tomcat:tomcat-tribes11.0.20GHSA-h468-7pvh-8vr8
Mavenorg.apache.tomcat:tomcat-tribesno fix listedGHSA-h468-7pvh-8vr8
Rocky Linux:10tomcat1:10.1.49-3.el10_2RLSA-2026:36788
Rocky Linux:8tomcat1:9.0.87-2.el8_10RLSA-2026:37137
Rocky Linux:9tomcat1:9.0.117-2.el9_8RLSA-2026:36879
Rocky Linux:10tomcat91:9.0.117-2.el10_2RLSA-2026:36790
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-29146
Ubuntu:25.10tomcat10no fix listedUBUNTU-CVE-2026-29146
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-29146
Ubuntu:25.10tomcat11no fix listedUBUNTU-CVE-2026-29146
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-29146
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-29146
Ubuntu:25.10tomcat9no fix listedUBUNTU-CVE-2026-29146
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-29146

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.1810.0.0-M1 – through 10.1.529.0.13 – through 9.0.1158.5.38 – through 8.5.1007.0.100 – through 7.0.109

Weakness: CWE-209, CWE-642, CWE-1240 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References