Vulnerability · Published Apr 9, 2026 · Assigned by apache

CVE-2026-29129Apache Tomcat: TLS cipher order is not preserved

High 7.5

In plain English

A high-severity broken cryptography in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.3%top 81.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Configured cipher preference order not preserved vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10tomcat91:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-admin-webapps1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-docs-webapp1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-el-3.0-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-jsp-2.3-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-lib1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-servlet-4.0-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-webapps1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
Debian:12tomcat1010.1.55-1~deb12u1DEBIAN-CVE-2026-29129
Debian:13tomcat1010.1.55-1~deb13u1DEBIAN-CVE-2026-29129
Debian:14tomcat1010.1.54-1DEBIAN-CVE-2026-29129
Debian:13tomcat1111.0.22-1~deb13u1DEBIAN-CVE-2026-29129
Debian:14tomcat1111.0.21-1DEBIAN-CVE-2026-29129
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-29129
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-29129
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-29129
Mavenorg.apache.tomcat.embed:tomcat-embed-core9.0.116GHSA-69cc-cv78-qc8g
Mavenorg.apache.tomcat.embed:tomcat-embed-core10.1.53GHSA-69cc-cv78-qc8g
Mavenorg.apache.tomcat.embed:tomcat-embed-core11.0.20GHSA-69cc-cv78-qc8g
Mavenorg.apache.tomcat:tomcat11.0.20GHSA-69cc-cv78-qc8g
Mavenorg.apache.tomcat:tomcat9.0.116GHSA-69cc-cv78-qc8g
Mavenorg.apache.tomcat:tomcat10.1.53GHSA-69cc-cv78-qc8g
Mavenorg.apache.tomcat:tomcat-coyote11.0.20GHSA-69cc-cv78-qc8g
Mavenorg.apache.tomcat:tomcat-coyote10.1.53GHSA-69cc-cv78-qc8g
Mavenorg.apache.tomcat:tomcat-coyote9.0.116GHSA-69cc-cv78-qc8g
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-29129
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-29129

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.16 – through 11.0.1810.1.51 – through 10.1.529.0.114 – through 9.0.115

Weakness: CWE-327 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References