Vulnerability · Published Jul 30, 2026 · Assigned by apache

CVE-2026-28813Apache JSPWiki: JSPWiki vulnerable to JSON hijacking

High 8.8

In plain English

A high-severity cross-site request forgery in Apache JSPWiki from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities).

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.3%top 80.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Apache JSPWiki, up to 2.12.3, is vulnerable to JSON Hijacking, which leads to csrf vulnerabilities. Users are recommended to upgrade to version 2.12.4, which fixes this issue.

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache JSPWiki 0 – before 2.12.4

Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References