Vulnerability · Published Mar 4, 2026 · Assigned by GitHub_M

CVE-2026-28784Craft is affected by potential authenticated Remote Code Execution via Twig SSTI

High 8.6

In plain English

A high-severity security flaw in cms from craftcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)0.6%top 51.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Craft is a content management system (CMS). Prior to 5.8.22 and 4.16.18, it is possible to craft a malicious payload using the Twig map filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. For this to work, you must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled for this to work, which is against our recommendations for any non-dev environment. Alternatively, you can have a non-administrator account with allowAdminChanges disabled, but you have access to the System Messages utility. Users should update to the patched versions (5.8.22 and 4.16.18) to mitigate the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcraftcms/cms5.9.0-beta.1GHSA-qc86-q28f-ggww
Packagistcraftcms/cms4.17.0-beta.1GHSA-qc86-q28f-ggww

Affected products (as reported)

VendorProductVersions
craftcms cms >= 5.0.0-RC1, < 5.9.0-beta.1>= 4.0.0-RC1, < 4.17.0-beta.1

Weakness: CWE-1336 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References