Vulnerability · Published Mar 4, 2026 · Assigned by GitHub_M
CVE-2026-28783Craft has a Twig Function Blocklist Bypass
Critical 9.4
In plain English
A critical-severity code injection in cms from craftcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Craft is a content management system (CMS). Prior to 5.9.0-beta.1 and 4.17.0-beta.1, Craft CMS implements a blocklist to prevent potentially dangerous PHP functions from being called via Twig non-Closure arrow functions. In order to be able to successfully execute this attack, you need to either have allowAdminChanges enabled on production, or a compromised admin account, or an account with access to the System Messages utility. Several PHP functions are not included in the blocklist, which could allow malicious actors with the required permissions to execute various types of payloads, including RCEs, arbitrary file reads, SSRFs, and SSTIs. This vulnerability is fixed in 5.9.0-beta.1 and 4.17.0-beta.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | craftcms/cms | 5.9.0-beta.1 | GHSA-5fvc-7894-ghp4 |
| Packagist | craftcms/cms | 4.17.0-beta.1 | GHSA-5fvc-7894-ghp4 |
Affected products (as reported)
Weakness: CWE-94, CWE-184, CWE-1336 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
References
- https://github.com/craftcms/cms/security/advisories/GHSA-5fvc-7894-ghp4 x_refsource_CONFIRM
- https://github.com/craftcms/cms/pull/18208 x_refsource_MISC