Vulnerability · Published Mar 16, 2026 · Assigned by GitHub_M
CVE-2026-28490Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle
High 8.3
In plain English
A high-severity broken cryptography in authlib from authlib. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.9, a cryptographic padding oracle vulnerability was identified in the Authlib Python library concerning the implementation of the JSON Web Encryption (JWE) RSA1_5 key management algorithm. Authlib registers RSA1_5 in its default algorithm registry without requiring explicit opt-in, and actively destroys the constant-time Bleichenbacher mitigation that the underlying cryptography library implements correctly. This issue has been patched in version 1.6.9.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | python-authlib | 1.2.0-1+deb12u2 | DEBIAN-CVE-2026-28490 |
| Debian:13 | python-authlib | no fix listed | DEBIAN-CVE-2026-28490 |
| Debian:14 | python-authlib | 1.6.9-1 | DEBIAN-CVE-2026-28490 |
| PyPI | authlib | 1.6.9 | PYSEC-2026-2116 |
| PyPI | authlib | 1.6.9 | GHSA-7432-952r-cw78 |
| Ubuntu:25.10 | python-authlib | no fix listed | UBUNTU-CVE-2026-28490 |
| Ubuntu:26.10 | python-authlib | no fix listed | UBUNTU-CVE-2026-28490 |
Affected products (as reported)
Weakness: CWE-203, CWE-327 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/authlib/authlib/security/advisories/GHSA-7432-952r-cw78 x_refsource_CONFIRM
- https://github.com/authlib/authlib/commit/48b345f29f6c459f11c6a40162b6c0b742ef2e22 x_refsource_MISC
- https://github.com/authlib/authlib/releases/tag/v1.6.9 x_refsource_MISC