Vulnerability · Published Mar 5, 2026 · Assigned by GitHub_M

CVE-2026-28343CKEditor: Cross-site scripting (XSS) in the HTML Support package

Medium 6.4

In plain English

A medium-severity cross-site scripting in ckeditor5 from ckeditor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.4Medium
Exploit odds (30 days)0.3%top 75.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. Starting in version 29.0.0 and prior to version 47.6.0, a cross-site scripting (XSS) vulnerability has been discovered in the General HTML Support feature. This vulnerability could be triggered by inserting specially crafted markup, leading to unauthorized JavaScript code execution, if the editor instance used an unsafe General HTML Support configuration. This issue has been patched in version 47.6.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:25.10ckeditorno fix listedUBUNTU-CVE-2026-28343
Ubuntu:22.04:LTSckeditor3no fix listedUBUNTU-CVE-2026-28343
Ubuntu:24.04:LTSckeditor3no fix listedUBUNTU-CVE-2026-28343
Ubuntu:22.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2026-28343
Ubuntu:24.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2026-28343
Ubuntu:25.10ldap-account-managerno fix listedUBUNTU-CVE-2026-28343
Ubuntu:26.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2026-28343
Ubuntu:22.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2026-28343
Ubuntu:24.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2026-28343
Ubuntu:25.10request-tracker4no fix listedUBUNTU-CVE-2026-28343
Ubuntu:26.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2026-28343
npm@ckeditor/ckeditor5-html-support47.6.0GHSA-jrqm-vmqc-gm93
npmckeditor547.6.0GHSA-jrqm-vmqc-gm93

Affected products (as reported)

VendorProductVersions
ckeditor ckeditor5 >= 29.0.0, < 47.6.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

References