Vulnerability · Published Mar 3, 2026 · Assigned by GitHub_M
CVE-2026-27971Qwik affected by unauthenticated RCE via server$ Deserialization
Critical 9.2
In plain English
A critical-severity unsafe deserialization in qwik from QwikDev. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 5.5% (higher than 93% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @builder.io/qwik | 1.19.1 | GHSA-p9x5-jp3h-96mm |
Affected products (as reported)
Weakness: CWE-502 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/QwikDev/qwik/security/advisories/GHSA-p9x5-jp3h-96mm x_refsource_CONFIRM