Vulnerability · Published Mar 3, 2026 · Assigned by GitHub_M
CVE-2026-27601Underscore.js has unlimited recursion in _.flatten and _.isEqual, potential for DoS attack
High 8.2
In plain English
A high-severity resource allocation without limits in underscore from jashkenas. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | underscore | no fix listed | DEBIAN-CVE-2026-27601 |
| Debian:13 | underscore | no fix listed | DEBIAN-CVE-2026-27601 |
| Debian:14 | underscore | 1.13.8~dfsg+~1.13.0-1 | DEBIAN-CVE-2026-27601 |
| Ubuntu:22.04:LTS | ruby-rails-assets-underscore | no fix listed | UBUNTU-CVE-2026-27601 |
| Ubuntu:24.04:LTS | ruby-rails-assets-underscore | no fix listed | UBUNTU-CVE-2026-27601 |
| npm | underscore | 1.13.8 | GHSA-qpx9-hpmf-5gmw |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jashkenas | underscore | < 1.13.8 |
Weakness: CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/jashkenas/underscore/security/advisories/GHSA-qpx9-hpmf-5gmw x_refsource_CONFIRM
- https://github.com/jashkenas/underscore/commit/411e222eb0ca5d570cc4f6315c02c05b830ed2b4 x_refsource_MISC
- https://github.com/jashkenas/underscore/commit/a6e23ae9647461ec33ad9f92a2ecfc220eea0a84 x_refsource_MISC