Vulnerability · Published Apr 3, 2026 · Assigned by GitHub_M
CVE-2026-27124FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities
High 8.2
In plain English
A high-severity security flaw in fastmcp from jlowin. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
FastMCP is the standard framework for building MCP applications. Prior to version 3.2.0, while testing the GitHubProvider OAuth integration, which allows authentication to a FastMCP MCP server via a FastMCP OAuthProxy using GitHub OAuth, it was discovered that the FastMCP OAuthProxy does not properly validate the user's consent upon receiving the authorization code from GitHub. In combination with GitHub’s behavior of skipping the consent page for previously authorized clients, this introduces a Confused Deputy vulnerability. This issue has been patched in version 3.2.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | fastmcp | 3.2.0 | GHSA-rww4-4w9c-7733 |
| PyPI | fastmcp | 3.2.0 | PYSEC-2026-2476 |
Affected products (as reported)
Weakness: CWE-441 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/PrefectHQ/fastmcp/security/advisories/GHSA-rww4-4w9c-7733 x_refsource_CONFIRM