Vulnerability · Published Feb 20, 2026 · Assigned by GitHub_M
CVE-2026-26974Sylde has Improper Control of Generation of Code
High 7.6
In plain English
A high-severity security flaw in Slyde from Tygo-van-den-Hurk. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @tygo-van-den-hurk/slyde | 0.0.5 | GHSA-w7h5-55jg-cq2f |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Tygo-van-den-Hurk | Slyde | < 0.0.5 |
Weakness: CWE-829 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N