Vulnerability · Published Jul 15, 2026 · Assigned by apache
CVE-2026-26032Apache Ivy: PackagerResolver path traversal vulnerability
Medium 5.4
In plain English
A medium-severity path traversal in Apache Ivy from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities).
Official description
The PackagerResolver of Apache Ivy is able to download online artifacts and to (re)package them in a format defined by a packager.xml file. This repackaging is done by an Ant script, which is stored in a subdirectory of the configured "buildRoot" directory. This subdirectory is calculated based on modules coordinates, like the organisation, name or version. If one of the coordinates contains "../" sequences - which are valid characters for Ivy coordinates in general- it is possible to break out of the configured "buildRoot" directory where other files can be overwritten. In order to exploit this vulnerability an attacker needs to have access to a packager repository and add or modify the coordinates in ivy.xml files to have such "../" sequences. Users of Apache Ivy 2.0.0 to 2.5.3 (inclusive) should upgrade to Ivy 2.6.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:22.04:LTS | ivy | no fix listed | UBUNTU-CVE-2026-26032 |
| Ubuntu:24.04:LTS | ivy | no fix listed | UBUNTU-CVE-2026-26032 |
| Ubuntu:26.04:LTS | ivy | no fix listed | UBUNTU-CVE-2026-26032 |
| Ubuntu:26.10 | ivy | no fix listed | UBUNTU-CVE-2026-26032 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Ivy | 2.0.0 – through 2.5.3 |
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N