Vulnerability · Published Feb 9, 2026 · Assigned by GitHub_M
CVE-2026-25958Cube privilege escalation via a specially crafted request
High 7.7
In plain English
A high-severity security flaw in cube from cube-js. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.4%top 67.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @cubejs-backend/server-core | 1.0.14 | GHSA-v226-32c7-x2v7 |
| npm | @cubejs-backend/server-core | 1.4.2 | GHSA-v226-32c7-x2v7 |
| npm | @cubejs-backend/server-core | 1.5.13 | GHSA-v226-32c7-x2v7 |
Affected products (as reported)
Weakness: CWE-807 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
References
- https://github.com/cube-js/cube/security/advisories/GHSA-v226-32c7-x2v7 x_refsource_CONFIRM