Vulnerability · Published Feb 9, 2026 · Assigned by GitHub_M
CVE-2026-25957Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request
Medium 6.5
In plain English
A medium-severity security flaw in cube from cube-js. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.4%top 62.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @cubejs-backend/server-core | 1.4.2 | GHSA-9vph-2hvm-x66g |
| npm | @cubejs-backend/server-core | 1.5.13 | GHSA-9vph-2hvm-x66g |
Affected products (as reported)
Weakness: CWE-755 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/cube-js/cube/security/advisories/GHSA-9vph-2hvm-x66g x_refsource_CONFIRM