Vulnerability · Published Feb 11, 2026 · Assigned by GitHub_M
CVE-2026-25924Kanboard is Missing Access Control on Plugin Installation leading to Administrative RCE
High 8.5
In plain English
A high-severity incorrect authorization in kanboard from kanboard. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Kanboard is project management software focused on Kanban methodology. Prior to 1.2.50, a security control bypass vulnerability in Kanboard allows an authenticated administrator to achieve full Remote Code Execution (RCE). Although the application correctly hides the plugin installation interface when the PLUGIN_INSTALLER configuration is set to false, the underlying backend endpoint fails to verify this security setting. An attacker can exploit this oversight to force the server to download and install a malicious plugin, leading to arbitrary code execution. This vulnerability is fixed in 1.2.50.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | kanboard | 1.2.50+ds-1 | DEBIAN-CVE-2026-25924 |
| Ubuntu:22.04:LTS | kanboard-cli | no fix listed | UBUNTU-CVE-2026-25924 |
| Ubuntu:24.04:LTS | kanboard-cli | no fix listed | UBUNTU-CVE-2026-25924 |
| Ubuntu:22.04:LTS | python-kanboard | no fix listed | UBUNTU-CVE-2026-25924 |
| Ubuntu:24.04:LTS | python-kanboard | no fix listed | UBUNTU-CVE-2026-25924 |
| Ubuntu:25.10 | python-kanboard | no fix listed | UBUNTU-CVE-2026-25924 |
| Ubuntu:26.04:LTS | python-kanboard | no fix listed | UBUNTU-CVE-2026-25924 |
| Ubuntu:26.10 | python-kanboard | no fix listed | UBUNTU-CVE-2026-25924 |
Affected products (as reported)
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H