Vulnerability · Published Feb 6, 2026 · Assigned by GitHub_M
CVE-2026-25593OpenClaw Affected by Unauthenticated Local RCE via WebSocket config.apply
High 8.4
In plain English
A high-severity OS command injection in openclaw from openclaw. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenClaw is a personal AI assistant. Prior to 2026.1.20, an unauthenticated local client could use the Gateway WebSocket API to write config via config.apply and set unsafe cliPath values that were later used for command discovery, enabling command injection as the gateway user. This vulnerability is fixed in 2026.1.20.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | openclaw | 2026.1.20 | GHSA-g55j-c2v4-pjcg |
Affected products (as reported)
Weakness: CWE-78, CWE-306 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-g55j-c2v4-pjcg x_refsource_CONFIRM