Vulnerability · Published Mar 12, 2026 · Assigned by GitHub_M
CVE-2026-25529Postal has HTML injection / XSS in message view
High 8.1
In plain English
A high-severity cross-site scripting in postal from postalserver. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities).
Official description
Postal is an open source SMTP server. Postal versions less than 3.3.5 had a HTML injection vulnerability that allowed unescaped data to be included in the admin interface. The primary way for unescaped data to be added is via the API's "send/raw" method. This could allow arbitrary HTML to be injected in to the page which may modify the page in a misleading way or allow for unauthorised javascript to be executed. Fixed in 3.3.5 and higher.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| postalserver | postal | < 3.3.5 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
References
- https://github.com/postalserver/postal/security/advisories/GHSA-5f4r-5jpr-rfhc x_refsource_CONFIRM