Vulnerability · Published Feb 3, 2026 · Assigned by GitHub_M
CVE-2026-25237PEAR is Vulnerable to PHP Code Execution via preg_replace /e in Bug Update Emails
Critical 9.2
In plain English
A critical-severity security flaw in pearweb from pear. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities).
Severity (CVSS 4.0)9.2Critical
Exploit odds (30 days)0.5%top 60.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
PEAR is a framework and distribution system for reusable PHP components. Prior to version 1.33.0, use of preg_replace() with the /e modifier in bug update email handling can enable PHP code execution if attacker-controlled content reaches the evaluated replacement. This issue has been patched in version 1.33.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:22.04:LTS | php-pear | no fix listed | UBUNTU-CVE-2026-25237 |
| Ubuntu:24.04:LTS | php-pear | no fix listed | UBUNTU-CVE-2026-25237 |
| Ubuntu:25.10 | php-pear | no fix listed | UBUNTU-CVE-2026-25237 |
Affected products (as reported)
Weakness: CWE-624 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/pear/pearweb/security/advisories/GHSA-vhw6-hqh9-8r23 x_refsource_CONFIRM