Vulnerability · Published Feb 12, 2026 · Assigned by GitHub_M

CVE-2026-24894FrankenPHP leaks session data between requests in worker mode

High 8.7

In plain English

A high-severity privilege mismanagement in frankenphp from php. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.5%top 57.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

FrankenPHP is a modern application server for PHP. Prior to 1.11.2, when running FrankenPHP in worker mode, the $_SESSION superglobal is not correctly reset between requests. This allows a subsequent request processed by the same worker to access the $_SESSION data of the previous request (potentially belonging to a different user) before session_start() is called. This vulnerability is fixed in 1.11.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/dunglas/frankenphp1.11.2GHSA-r3xh-3r3w-47gp
Gogithub.com/dunglas/frankenphp1.11.2GO-2026-4489

Affected products (as reported)

VendorProductVersions
php frankenphp < 1.11.2

Weakness: CWE-269, CWE-384, CWE-613 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References