Vulnerability · Published Jan 16, 2026 · Assigned by GitHub_M

CVE-2026-23643CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting

Medium 5.4

In plain English

A medium-severity cross-site scripting in cakephp from cakephp. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.3%top 79.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcakephp/cakephp5.2.12GHSA-qh8m-9qxx-53m5
Packagistcakephp/cakephp5.3.1GHSA-qh8m-9qxx-53m5
Ubuntu:22.04:LTScakephpno fix listedUBUNTU-CVE-2026-23643

Affected products (as reported)

VendorProductVersions
cakephp cakephp >= 5.2.10, < 5.2.12>= 5.3.0, < 5.3.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

References