Vulnerability · Published Jan 13, 2026 · Assigned by GitHub_M

CVE-2026-22871GuardDog Path Traversal Vulnerability Leads to Arbitrary File Overwrite and RCE

High 8.7

In plain English

A high-severity path traversal in guarddog from DataDog. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)1.1%top 35.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

GuardDog is a CLI tool to identify malicious PyPI packages. Prior to 2.7.1, there is a path traversal vulnerability exists in GuardDog's safe_extract() function that allows malicious PyPI packages to write arbitrary files outside the intended extraction directory, leading to Arbitrary File Overwrite and Remote Code Execution on systems running GuardDog. This vulnerability is fixed in 2.7.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIguarddog2.7.1GHSA-xg9w-vg3g-6m68
PyPIguarddog2.7.1PYSEC-2026-1430

Affected products (as reported)

VendorProductVersions
DataDog guarddog < 2.7.1

Weakness: CWE-22 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References