Vulnerability · Published Jan 12, 2026 · Assigned by GitHub_M
CVE-2026-22771Envoy Extension Policy lua scripts injection causes arbitrary command execution
High 8.8
In plain English
A high-severity code injection in gateway from envoyproxy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.5.7 and 1.6.2, EnvoyExtensionPolicy Lua scripts executed by Envoy proxy can be used to leak the proxy's credentials. These credentials can then be used to communicate with the control plane and gain access to all secrets that are used by Envoy proxy, e.g. TLS private keys and credentials used for downstream and upstream communication. This vulnerability is fixed in 1.5.7 and 1.6.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/envoyproxy/gateway | 1.6.2 | GHSA-xrwg-mqj6-6m22 |
| Go | github.com/envoyproxy/gateway | 1.5.7 | GHSA-xrwg-mqj6-6m22 |
| Go | github.com/envoyproxy/gateway | 1.5.7, 1.6.2 | GO-2026-4312 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| envoyproxy | gateway | < 1.5.7>= 1.6.0-rc.0, < 1.6.2 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/envoyproxy/gateway/security/advisories/GHSA-xrwg-mqj6-6m22 x_refsource_CONFIRM
- https://access.redhat.com/security/cve/CVE-2026-22771 vdb-entry, x_refsource_REDHAT
- RHBZ#2428735 issue-tracking, x_refsource_REDHAT
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-22771.json x_sadp-csaf-vex