Vulnerability · Published Jan 10, 2026 · Assigned by GitHub_M
CVE-2026-22611AWS SDK for .NET V4 adopted defense in depth enhancement for region parameter value
Low 3.7
In plain English
A low-severity improper input validation in aws-sdk-net from aws. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
AWS SDK for .NET works with Amazon Web Services to help build scalable solutions with Amazon S3, Amazon DynamoDB, Amazon Glacier, and more. From versions 4.0.0 to before 4.0.3.3, Customer applications could be configured to improperly route AWS API calls to non-existent or non-AWS hosts. This notification is related to the use of specific values for the region input field when calling AWS services. An actor with access to the environment in which the SDK is used could set the region input field to an invalid value. This issue has been patched in version 4.0.3.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| NuGet | awssdk.core | 4.0.3.3 | GHSA-9cvc-h2w8-phrp |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| aws | aws-sdk-net | >= 4.0.0, < 4.0.3.3 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
References
- https://github.com/aws/aws-sdk-net/security/advisories/GHSA-9cvc-h2w8-phrp x_refsource_CONFIRM