Vulnerability · Published Jan 8, 2026 · Assigned by GitHub_M

CVE-2026-21872NiceGUI apps are vulnerable to XSS which uses `ui.sub_pages` and render arbitrary user-provided links

Medium 6.1

In plain English

A medium-severity cross-site scripting in nicegui from zauberzeug. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.3%top 80.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

NiceGUI is a Python-based UI framework. From versions 2.22.0 to 3.4.1, an unsafe implementation in the click event listener used by ui.sub_pages, combined with attacker-controlled link rendering on the page, causes XSS when the user actively clicks on the link. This issue has been patched in version 3.5.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPInicegui3.5.0GHSA-m7j5-rq9j-6jj9
PyPInicegui3.5.0PYSEC-2026-1701

Affected products (as reported)

VendorProductVersions
zauberzeug nicegui >= 2.22.0, < 3.5.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References