Vulnerability · Published Feb 12, 2026 · Assigned by PostgreSQL
CVE-2026-2007PostgreSQL pg_trgm heap buffer overflow writes pattern onto server memory
High 8.2
In plain English
A high-severity heap buffer overflow in PostgreSQL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Heap buffer overflow in PostgreSQL pg_trgm allows a database user to achieve unknown impacts via a crafted input string. The attacker has limited control over the byte patterns to be written, but we have not ruled out the viability of attacks that lead to privilege escalation. PostgreSQL 18.1 and 18.0 are affected.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | postgresql18 | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-contrib | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-docs | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-plperl | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-plpython3 | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-private-devel | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-private-libs | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-server | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-server-devel | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-static | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-test | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-test-rpm-macros | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-upgrade | 18.3-1.el10_2 | ALSA-2026:19009 |
| AlmaLinux:10 | postgresql18-upgrade-devel | 18.3-1.el10_2 | ALSA-2026:19009 |
| Alpine:v3.20 | postgresql15 | 15.16-r0, 15.17-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.21 | postgresql15 | 15.17-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.22 | postgresql15 | 15.16-r0, 15.17-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.20 | postgresql16 | 16.12-r0, 16.13-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.21 | postgresql16 | 16.12-r0, 16.13-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.22 | postgresql16 | 16.12-r0, 16.13-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.23 | postgresql16 | 16.12-r0, 16.13-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.24 | postgresql16 | 16.12-r0, 16.13-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.21 | postgresql17 | 17.8-r0, 17.9-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.22 | postgresql17 | 17.8-r0, 17.9-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.23 | postgresql17 | 17.8-r0, 17.9-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.24 | postgresql17 | 17.8-r0, 17.9-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.23 | postgresql18 | 18.2-r0 | ALPINE-CVE-2026-2007 |
| Alpine:v3.24 | postgresql18 | 18.2-r0 | ALPINE-CVE-2026-2007 |
| Debian:14 | postgresql-18 | 18.2-1 | DEBIAN-CVE-2026-2007 |
| Rocky Linux:10 | postgresql18 | 0:18.3-1.el10 | RLSA-2026:19009 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| n/a | PostgreSQL | 18 – before 18.2 |
Weakness: CWE-122, CWE-120 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
References
- https://www.postgresql.org/support/security/CVE-2026-2007/
- https://access.redhat.com/security/cve/CVE-2026-2007 vdb-entry, x_refsource_REDHAT
- RHBZ#2439320 issue-tracking, x_refsource_REDHAT
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-2007.json x_sadp-csaf-vex
- https://access.redhat.com/errata/RHSA-2026:19009 vendor-advisory, x_refsource_REDHAT
- https://access.redhat.com/errata/RHSA-2026:8756 vendor-advisory, x_refsource_REDHAT