Vulnerability · Published Sep 6, 2026 · Assigned by PostgreSQL
CVE-2026-19633PostgreSQL Anonymizer: unprivileged masked users can execute code via operators, domain casts and view subqueries
High 8.8
In plain English
A high-severity SQL injection in PostgreSQL Anonymizer from DALIBO. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities).
Official description
PostgreSQL Anonymizer contains a vulnerability that allows unprivileged masked users to execute arbitrary code by abusing operators, domain casts, or view subqueries that carry untrusted expressions. When these objects are evaluated in the context of the extension’s masking mechanisms, the malicious code can run with elevated privileges. The issue is fixed in PostgreSQL Anonymizer 3.1.4 and later versions
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| DALIBO | PostgreSQL Anonymizer | 1 – before 3.1.4 |
Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H