Vulnerability · Published Sep 4, 2026 · Assigned by openjs
CVE-2026-18540undici vulnerable to downstream response splitting via retry interceptor
Low 3.7
In plain English
A low-severity security flaw in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
undici's retry interceptor can append the body of a ranged retry response to bytes already delivered from an earlier partial response while still presenting the original response's status and headers. This happens when an upstream server delivers part of a body without a trustworthy resume checkpoint, for example a non-success response whose headers were already sent or a partial-content response with an unusable content range, then closes the connection and answers the resumed range request with more bytes. As a result the response body can be longer than the Content-Length that the application observes. An application that relays such a response to a downstream HTTP/1.1 peer without normalizing the framing can emit a body that exceeds the forwarded Content-Length, and the excess bytes can be interpreted as the start of a following response, which enables downstream response splitting or desynchronization. Exploitation requires an attacker-controlled upstream server and an application that forwards the response through a framing-sensitive path. This affects undici versions before 6.28.1, from 7.0.0 up to 7.29.1, and from 8.0.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-undici | no fix listed | DEBIAN-CVE-2026-18540 |
| Debian:13 | node-undici | no fix listed | DEBIAN-CVE-2026-18540 |
| Debian:14 | node-undici | 8.10.2+dfsg+~cs3.2.2-1 | DEBIAN-CVE-2026-18540 |
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-18540 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-18540 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-18540 |
| npm | undici | 8.10.2 | GHSA-r53p-7pc4-xj5r |
| npm | undici | 7.29.1 | GHSA-r53p-7pc4-xj5r |
| npm | undici | 6.28.1 | GHSA-r53p-7pc4-xj5r |
Affected products (as reported)
Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N